[Monitoring] (Thailand) Intermittently failure detected on Debit card payment

Incident Report for Omise

Monitoring

We experienced a technical issue from ITMX, which resulted in intermittent failures between 07:20 and 10:05 (GMT+7) today. During this period, some Thai debit card transactions may have failed.

Our teams investigated the issue and coordinated with our acquiring partner to resolve it immediately. The service is now fully operational.

We sincerely apologize for any inconvenience this may have caused. For any questions or concerns regarding this incident, please contact us at support@omise.co.

Omise Payments
Posted Nov 28, 2025 - 11:19 GMT+07:00

Investigating

We are currently investigating a technical issue affecting debit card payment transaction, which is beginning on Friday 28th November at 07:20 (GMT+7).

This may be impacting some Thailand-based merchants, where certain debit card payment charges may be failing during this time.

Our team is actively working to identify the root cause with our payment processor and resolve the issue as soon as possible. We will share updates as they become available.

We apologize for the inconvenience this may be causing. For any questions or concerns, please contact us at support@omise.co.

Omise
Posted Nov 28, 2025 - 08:46 GMT+07:00
This incident affects: Debit cards (TH) (Bangkok Bank (TH), Kasikorn Bank (TH), Krungsri (TH), Krungthai (TH), Siam Commercial Bank (TH), TMBThanachart Bank (TH)).