We experienced a technical issue which had affected TouchNGo payment services between Wednesday, 26th November at 17:03 to Thursday, 27th November at 17:15 (GMT+8), during which, some TouchNGo transactions are failed.
Our teams had investigated and informed our acquiring partner to rectify the issue immediately. The issue is now resolved.
We sincerely apologize for any inconvenience this may have caused. For questions or concerns regarding this incident, please reach out to support@omise.co
Omise
Posted Nov 27, 2025 - 18:24 GMT+07:00
Investigating
We are currently investigating a technical issue affecting TouchNGo transactions, which is beginning on Wednesday, 26th November at 17:03 (GMT+8).
This may be impacting some Malaysia-based merchants, where certain TouchNGo payment charges may be failing during this time.
Our team is actively working to identify the root cause with our payment processor and resolve the issue as soon as possible. We will share updates as they become available.
We apologize for the inconvenience this may be causing. For any questions or concerns, please contact us at support@omise.co.
Omise
Posted Nov 27, 2025 - 15:02 GMT+07:00
This incident affected: Alternative Payments (Touch 'n Go (MY)).