[External] Kasikorn Online Direct Debit will be unavailable on Tue, Nov 18 00:00-02:30 (GMT+7)

Scheduled for Nov 18, 00:00 - 02:30 GMT+07:00

Update

Kasikorn Online Direct Debit have change maintenance schedule which will be unavailable on Tue, Nov 18 00:00-02:30 (GMT+7)
Posted Oct 16, 2025 - 14:29 GMT+07:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 11:10 GMT+07:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 11:10 GMT+07:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 11:06 GMT+07:00

Scheduled

Kasikorn Online Direct Debit will be unavailable on Fri, Oct 17 00:00-02:30 (GMT+7)
Posted Oct 14, 2025 - 10:59 GMT+07:00
This scheduled maintenance affects: Online Direct Debit (Kasikorn Bank).